Forum

apache i PHP pod win home XP

[+] Twoje konto

Subskrybuj kanał najnowszych wypowiedzi w tym temacie

Wątek zamknięty Forum > Porady > Programowanie > apache i PHP pod win home XP

Idź do strony:1
Ocena: (Ocen: 0)
Wypowiedzi 1 - 9 z 9
 VIP nse Mężczyzna Kopiuj nick (83.30.94.*) |  
Wypowiedź dodana: 9 czerwca 2008, 18:49:25
« Opcje

Od pewnego czasu próbuje uruchomić u siebie na kompie Apache 2.0.63 i PHP 5.15 i coś mi nie wychodzi ... jak odpalam skrypt PHP to mi nic nie wyświetla ,a w pliku access.log jest taki wpis 127.0.0.1 - - [05/Jun/2008:19:41:49 +0200] "GET /strona/test.php HTTP/1.1" 200 34 Może ktoś by mi pomógł odpalić te PHP ?

 Gość REKLAMA Kopiuj nick (*->*)
Wypowiedź dodana: 9 czerwca 2008, 18:49:26

 Zarejestrowany Sbstn-S Mężczyzna Kopiuj nick (83.25.87.*) |  
Wypowiedź dodana: 10 czerwca 2008, 11:24:13 | Wypowiedź edytowana Ostatnio edytowana: 10 czerwca 2008, 11:24:43 po raz 1-wszy przez: Sbstn-S
« Opcje

dewizę mieć: w straconej trzeba walczyć sprawie
marzeniem żyć, tak przecież najciekawiej
potężnym strach dać, maluczkim dawać pokrzepienie
wciąż naprzód iść i nie mieć czasu na zmęczenie
wyszczerbić miecz, lecz czyste mieć sumienie

 Zarejestrowany, zwieszony grocal Kopiuj nick (84.10.103.*) |  
Wypowiedź dodana: 10 czerwca 2008, 18:16:40
« Opcje

Nie ma potrzeby wyważać otwartych drzwi. Stosuj zasadę KISS i ściągnij "gotowca".

http://www.apachefriends.org/en/xampp-windows.html

 Zarejestrowany Sbstn-S Mężczyzna Kopiuj nick (83.25.86.*) |  
Wypowiedź dodana: 10 czerwca 2008, 18:51:35
« Opcje

Ściągając gotowca człowiek nic się nie nauczy.


dewizę mieć: w straconej trzeba walczyć sprawie
marzeniem żyć, tak przecież najciekawiej
potężnym strach dać, maluczkim dawać pokrzepienie
wciąż naprzód iść i nie mieć czasu na zmęczenie
wyszczerbić miecz, lecz czyste mieć sumienie

 Zarejestrowany, zwieszony grocal Kopiuj nick (84.10.103.*) |  
Wypowiedź dodana: 10 czerwca 2008, 19:05:49 | Wypowiedź edytowana Ostatnio edytowana: 10 czerwca 2008, 19:06:27 po raz 1-wszy przez: grocal
« Opcje

Ściągając gotowca człowiek nic się nie nauczy.

Wbrew pozorom najlepiej uczyc sie na przykladach. Sciagasz taki pakiet, ktory dziala i od razu mozesz przejsc do rozgryzania configow apache'a, php.ini, mysqla i co tam jeszcze jest.

Sam wiesz, ze co innego ksiazkowa, manualowa wiedza a co innego praktyka. Poza tym pomoc w tym przypadku nie widzac ani configow i majac raptem jeden wiersz z loga jest dosc utrudniona. Osobiscie np. stawialbym na blad w konfiguracji interpretera php w httpd.conf, bo wyglada na to, ze pliki php zamiast sie parsowac, to gina w niebycie ale serwuja sie poprawnie (kod 200).

Tak czy inaczej - wiecej nauczylem sie w zyciu z analizy kodu niz z ksiazek :-)

No i jest jeszcze jeden argument - szybkosc. Czlowiek bedzie walczyl z konfiguracja zamiast postawic serwer szybko i bezbolesnie i zajac sie faktyczna praca. No chyba, ze praca bylo postawienie owego serwera :-)

 VIP nse Mężczyzna Kopiuj nick (83.30.107.*) |  
Wypowiedź dodana: 11 czerwca 2008, 16:04:20 | Wypowiedź edytowana Ostatnio edytowana: 11 czerwca 2008, 16:17:14 po raz 4-ty przez: nse
« Opcje

na końcu pliku htpd.conf dopisałem ScriptAlias /php/ "c:/serwer/php/"
AddType application/x-httpd-php .php
Action application/x-httpd-php "/php/php-cgi.exe"
próbowałem instalować gotowce i też ta sama historia ... miałem kiedyś postawionego apacha,PHP i MySQL pod win98 i wtedy nie miałem tylu problemów z uruchomieniem co teraz z uruchamianiem tych nowych wersji pod XP home ... muszę troszkę popracować nad przekazywaniem zmiennych między plikami w sesjach przy różnych ustawieniach na serwerach ... te aktualizacje programów na serwerach dają mi mocno w kość ...

 VIP nse Mężczyzna Kopiuj nick (83.30.66.*) |  
Wypowiedź dodana: 11 czerwca 2008, 17:02:54
« Opcje

Ok zainstalowałem gotowca i już mi działa ... , prawdo podobnie problem o który się potknąłem tkwił w złym ustawieniu zapory systemowej pod XP ... dzięki za podpowiedzi :-)

 Zarejestrowany Sbstn-S Mężczyzna Kopiuj nick (87.207.101.*) |  
Wypowiedź dodana: 30 października 2008, 10:03:07
« Opcje

Odświeżam wątek, nie ma sensu zakładać nowego. Apache 2.2.10, PHP 5.2.6, WinXP. PHP mam w ścieżce "E:\programowanie\PHP\", do httpd.conf mam dopisane dwie linijki

PHPIniDir "E:\programowanie\PHP\"
LoadModule php5_module "E:\programowanie\PHP\php5apache2_2.dll"

i nie działa. Sugestie?


dewizę mieć: w straconej trzeba walczyć sprawie
marzeniem żyć, tak przecież najciekawiej
potężnym strach dać, maluczkim dawać pokrzepienie
wciąż naprzód iść i nie mieć czasu na zmęczenie
wyszczerbić miecz, lecz czyste mieć sumienie

AvatarAdministrator Dżyszla Mężczyzna Kopiuj nick (83.2.108.*) |  
Wypowiedź dodana: 2 listopada 2008, 15:04:59
« Opcje

Po pierwsze, to zapisy związane są z serwerem Apacha, nie PHP, stąd dziwi mnie lokalizacjia

Po drugie Apache raczej używa backslashy do rozdzielania folderów, niezależnie od systemu.

Po trzecie nie widzę skojarzenia rozszerzenia z modułem (np: AddType application/x-httpd-php .php3 .php .phtml)

Jeśli poprzednie nie da rezultatu - podaj konfigurację PHP (php.ini).


mgr inż. Dżyszla

Nie odpisuję na problemy zgłaszane na e-mail lub PW!

Także dzięki firmie Netlook.pl możesz za darmo korzystać z tej strony!

 
Idź do strony:1

[+] Pokaż/odśwież listę czytających i monitorujących ten wątek

Podobne tematy:
Tytuł wątkuDziałWypowiedziWyświetleńOcenaOstatnia wypowiedź
Wątekudostępnianie plików w Windows XP HomePorady / Oprogramowanie, systemy operacyjne5377 15.11.2009 19:33:39

Wątek zamknięty - nie można już do niego dodawać nowych wypowiedzi

Subskrybuj kanał najnowszych wypowiedzi w tym temacie


Chcesz mieć też takie forum na swojej stronie? Napisz!

Strona istnieje od 25.01.2001
Ta strona używa plików Cookie
 
archive To tylko kopia strony wykonana przez robota internetowego! Aby wyświetlić aktualną zawartość przejdź do strony.
Ładowanie...

Optymalizowane dla przeglądarki Firefox
© Copyright 2001-2017 Dawid Najgiebauer. Wszelkie prawa zastrzeżone.
Ostatnia aktualizacja podstrony: 22.09.2014 12:12
Wszystkie czasy dla strefy czasowej: Europe/Warsaw